
Lesson Skill Matrix

Skill Exam Objective Objective 

Number

Using Macros Create and modify simple macros.

Enable macros in a document.

Display hidden ribbon tabs.

Copy custom styles, macros, and building blocks to 

other documents or templates.

4.1.3

1.1.6

1.1.7

1.1.2

Using 

QuickParts

Create QuickParts.

Manage building blocks.

Copy custom styles, macros, and building blocks to 

other documents or templates.

4.1.1

4.1.2

1.1.2

Linking 

Content

Link to external document content. 1.1.5

Using Macros, QuickParts, and Content Links
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A macro is a recorded sequence of commands to automate a task. It is a series of 

commands and actions that you can record and run whenever you need to perform the 

task. When you create a macro, you can run it manually or assign it to run whenever a 

specific key or series of keystrokes are pressed.

Take Note

A keyboard shortcut is a combination of two or more keys to perform a specific action. 

You might have already applied a keyboard shortcut to open a new document by 

pressing Ctrl+N or to bold text by pressing Ctrl+B. Word contains many preconfigured 

shortcuts, which are already assigned to a specific action. Therefore, you cannot use 

them for your own customized shortcuts.

Step by step           Assign Shortcut Keys

On the View tab, click the Macros drop-down arrow to open its menu (see Figure 

5-1).

1.

Figure 5-1

Macros menu

Click Record Macro to open the Record Macro dialog box (see Figure 5-2). In the 

dialog box, you need to specify a name for the macro and decide which option to 

use to assign a macro. You have two choices. You can assign a macro by button or 

by keyboard.

2.

GET READY. LAUNCH Word and CREATE a new blank document.

Using Macros
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Figure 5-2

Record Macro dialog box

In the Macro name text box, type Upcoming_Workshops. Spaces are not allowed; 

you must add an underscore. 

3.

Leave the default setting for the Store macro in drop-down list. The macro will be 

stored in All Documents (Normal.dotm). You want it stored there because you will 

need to access this macro on a monthly basis. If someone else is working on the 

computer and you've provided the person with the keyboard shortcut, he or she 

can access the macro also. 

4.

Take Note

The Normal.dotx template is the default template that Word 2016 attaches to any 

document you create or open. As long as you save your macro to that template, it 

will always be accessible in any document you open on that computer. If you save 

the macro to the new document you just created instead, then the macro will only 

be available in that document, but you will be able to copy it to any location and 

run it on any computer.

In the Description text box, type Use this table for all upcoming workshops.5.

Click the Keyboard button to open the Customize Keyboard dialog box as shown in 

Figure 5-3. 

6.
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Figure 5-3

Customize Keyboard dialog box

In the Press new shortcut key box, press Ctrl+T. This shortcut key is already 

assigned to the HangingIndent command, as shown in the dialog box.

7.

Press Backspace to remove Ctrl+T.8.

Press Ctrl+Alt+T. This shortcut key is already taken by the ™ Trademark command. 

It may take several attempts to find an unassigned shortcut key.

9.

Press Backspace to remove Ctrl+Alt+T.10.

Press Alt+T. Notice that this keystroke is not assigned.11.

Click the Assign button to assign this shortcut key to the new macro. The Alt+T 

command is moved to the Current keys box for this macro.

12.

Take Note

Word allows you to override assigned keyboard shortcuts, but this practice is not 

recommended, unless you are certain that no one using the computer will need 

them. The best practice is to find one that is unassigned.

Click Close. The changes will be assigned in the Normal template instead of 

Document1. This saves the macro on the computer where you are recording the 

macro. It can then be accessed by anyone who is working on that computer.

13.

PAUSE. LEAVE Word open for the next exercise.

Recording a Macro
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Recording a Macro

Once you determine which method you will use to assign the macro, the next step is 

recording your steps. While Word is recording a macro, you see the mouse pointer 

change to a recording pointer on your screen. At this point, every keystroke and mouse 

click is recorded. When working with macros, you cannot use the mouse to select text. In 

this exercise, you learn to record your steps to create and format a table.

The Record button has been enabled in the previous procedure; you should see the 

mouse pointer change to a recording pointer on your screen. As long as you see the 

icon on your document screen, you are still recording your steps. If you need to take a 

break, or do something that you do not want recorded, click the Pause Recording 

command in the Macros menu. If you pause during a macro, you can resume by clicking 

Resume Recorder.

Step by step           Record a Macro

On the Insert tab, in the Tables group, click the Table down-arrow and then click 

Insert Table. The Insert Table dialog box appears (see Figure 5-4).

1.

Figure 5-4

Insert Table dialog box

Create a table that contains 4 columns and 7 rows. Click OK. The new table appears 

in the document.

2.

Type the information shown in Table 5-1. Because you are recording a macro, you 

must press Tab to move to the next cell and then press Shift+Tab to move back to 

the previous cell.

3.

Workshop Name Date City Cost

Word 2016 February 20, 20XX San Antonio, TX $495

Excel 2016 March 15, 20XX Dallas, TX $495

GET READY. USE the document that is open from the previous exercise.
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PowerPoint 2016 April 28, 20XX Frisco, TX $495

Access 2016 May 15, 20XX San Antonio, TX $495

Outlook 2016 June 11, 20XX Austin, TX $495

MOS Exams July 30, 20XX San Antonio, TX $650

Table 5-1 

Workshop Information

After you type the data, on the Table Tools - Layout tab, in the Table group, click 

the Select down-arrow and then click Select Table. The entire table is now selected. 

While you are recording a macro, you cannot use your mouse to select text or 

tables. 

4.

On the Table Tools - Design tab, in the Table Styles group, click the More down-

arrow to display the gallery.

5.

In the Grid Tables group, select Grid Table 4 – Accent 6 to apply a style to the 

table.

6.

Use the arrow keys on the keyboard to move up to the first row, containing the 

headings.

7.

On the Table Tools - Layout tab, in the Table group, click the Select down-arrow 

and then click Select Row. 

8.

In the Alignment group, click Align Center. The table now appears as shown in 

Figure 5-5.

9.

Figure 5-5

Upcoming Workshop document

The next step is to stop recording. On the View tab, click the Macros down-arrow 

and then click Stop Recording.

10.

Take Note

After recording your first macro, you can access it quickly using the keyboard 

shortcut you specified. If you share your computer with another individual, this 

person too can use the keyboard shortcut to apply the macro, as long as you 

provide the person with the shortcut key. You can use this table for all upcoming 
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provide the person with the shortcut key. You can use this table for all upcoming 

workshops—all you have to do is change the data.

CLOSE the document without saving it. 11.

PAUSE. LEAVE Word open for the next exercise.

Running a Macro

Once you have recorded a macro and saved it to the Normal template, you can press 

the keyboard shortcut to run it in any blank or existing document. In this exercise, you 

learn to run your macro in a blank document.

Step by step           Run a Macro

Press Alt+T. The table automatically appears in your document. When you need to 

work with this table, you can now access it quickly, edit the data, and then save the 

document with a new filename.

1.

SAVE the document as Upcoming Workshops in the lesson folder on your flash 

drive and then CLOSE the file.

2.

Now, let's run the macro again another way. OPEN a blank document. 3.

On the View tab, click the Macros down-arrow and then click View Macros to open 

the Macros dialog box (see Figure 5-6).

4.

Figure 5-6

Macros dialog box

With the Upcoming_Workshops macro selected by default, click Run. The table 

appears in the document.

5.

GET READY. CREATE a new blank document.
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appears in the document.

CLOSE the document without saving.6.

PAUSE. LEAVE Word open for the next exercise.

Software Orientation

Controlling Macro Security

Macros can streamline your work, but you must also be concerned about how security works with 

macros. Macro security is concerned with active content in files that might come from a site that has 

no digital signature or from someone who has written malevolent code. If someone sends you a 

document that contains macros with active content, it might pose a security risk and harm your 

computer. A hacker is a person who writes malicious programs, such as malware intended to harm 

your computer or access your data illegally. Every day, we hear about hackers breaking into large 

company networks and accessing confidential information. Organizations have security in place to 

identify and stop anyone from accessing data on their networks, so it's important to know, when 

working with macros, who your trusted sources are. Word has a macro security feature that keeps 

track of trusted sources and locations. This macro security feature determines whether a macro is 

safe to run on your computer. You want reassurance that macros coming from other sources are 

generated by a trusted publisher. A digital signature is a code that identifies the company or person 

from which a file originates. Individuals can create their own digital signatures, but for them to be 

trustworthy, they must be issued by a trusted certificate authority. In this exercise, you learn to review 

the securities on your system.

Figure 5-7 

Developer tab

Use this figure as a reference throughout this lesson as well as the rest of this book.

Monitoring Macro Security

Macro security in Word 2016 consists of preventive measures that determine whether a 

macro is safe to run.

Step by step           Review Macro Security Settings

Click the File tab and then on the Backstage page, click Options. The Word Options

dialog box appears.

1.

In the Word Options dialog box, click Trust Center. The Trust Center screen appears 

(see Figure 5-8). On the Trust Center screen, Microsoft has provided links to articles 

on protecting your privacy, computer, and security.

2.

GET READY. CREATE a new blank document.
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Figure 5-8

Trust Center screen

Click the Trust Center Settings button. The Trust Center dialog box appears, 

displaying the Macro Settings page (see Figure 5-9). This is where you manage how 

macros run. You can choose to disable all macros with or without notification, 

disable all macros with the exception of those that are digitally signed, or enable all 

macros, which could harm your computer.

3.

Select the Trust access to the VBA project object model checkbox. This allows 

access to the Visual Basic for Applications object model. 

4.

Click the Cancel button to close the Trust Center dialog box.5.

PAUSE. LEAVE the Word Options dialog box open to use in the next exercise.
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Figure 5-9

Trust Center dialog box

Now you will learn to add the Developer tab to the ribbon.

Step by step           Use the Developer Tab

In the Word Options dialog box, click Customize Ribbon on the left pane. The 

Customize Ribbon page appears (see Figure 5-10). This screen is where you 

customize the Ribbon or, in this case, add a Ribbon tab that is hidden by default.

1.

Under Customize the Ribbon, select the Developer checkbox and then click OK. The 

Developer tab appears on the ribbon.

2.

Click the Developer tab to display its groups and commands. The Developer tab 

contains commands that are used with macros, which includes codes, templates, 

controls used in forms, add-ins, and more.

3.

GET READY. USE the document that is open from the previous exercise.

Take Note

Previously, you opened the Macros dialog box to run a macro that you created. On 

the Developer tab, in the Code group, you can access the Macros dialog box by 

clicking the Macros button. In the same group, you can record a macro and pause 

a recording—these are the same commands as those in the Macros group on the 

View tab. The Developer tab also contains more commands. The Macro Security 

button opens the Trust Center. This displays the macro settings for your computer. 
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button opens the Trust Center. This displays the macro settings for your computer. 

If you have a programming background or feel comfortable writing code, you can 

write your own macros using the Visual Basic editor

PAUSE. LEAVE Word open to use in the next exercise.

Figure 5-10

Customize Ribbon
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AutoText: A gallery containing snippets of text that you frequently use in your 

documents. By default, the AutoText gallery contains the name and initials of the 

current Word user. You can add any selected block of text to the gallery for later 

insertion into a document.



Document Properties: Every Word document contains property fields that specify 

its author and other information. Using Quick Parts, you can insert the information 

from any of these fields into the main body of a document.



Fields: Fields are placeholders containing information that is automatically 

updated when you insert them into a document. For example, the date field inserts 

the current date, but every time you open the document, the field is updated as 

the date changes.



Building Blocks: A gallery containing content of various types, including headers, 

footers, page numbers, cover pages, and watermarks, which you can add to your 

documents. 



Quick Parts is an umbrella term for a group of Word 2016 tools that enable you to insert 

preconfigured content anywhere in a document. By accessing the Quick Parts gallery, 

you can insert any of the following types of content:

Using Built-In Building Blocks

Building blocks contain built-in reusable content such as text, graphics, and objects, 

which are easy to manage and insert in a document for a quick format. Building blocks 

are organized in galleries and sorted by category. In the Building Blocks gallery, you can 

insert cover pages, headers, footers, page numbers, text boxes, and watermarks. 

Autotext is another term for one type of building block. You use both features the same 

way. Word provides a number of predefined building blocks, or you can create or 

customize your own building blocks for use in other documents. The Building Blocks 

Organizer tool provides a way to manage building blocks by editing, deleting, or 

inserting them. 

In the left pane of the dialog box, the built-in building blocks are listed by name. The 

Gallery column indicates the gallery that contains each building block, and the Category 

column indicates each element's general type. The Template column indicates name of 

the template in which the element is stored. By storing your building blocks in the 

default Building Blocks.dotx template file, you make them available to all of your 

documents. You can use the buttons at the bottom of the dialog box to delete and edit 

selected building blocks. The right pane previews your selections.

In this exercise, you learn to use built-in building blocks and insert fields in a document. 

Step by step           Use Built-In Building Blocks

GET READY. OPEN the Hosting document from the data files for this lesson.

Using Quick Parts 
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On the Insert tab, in the Text group, click the Quick Parts button to display the 

Quick Parts menu, as shown in Figure 5-11.

1.

Figure 5-11

Quick Parts menu

Click Building Blocks Organizer to display the Building Blocks Organizer dialog box 

(see Figure 5-12).

2.

Figure 5-12

Building Blocks organizer dialog box

Click the Name heading to sort the building blocks by name.3.

Scroll down the list and then select the Confidential 1 watermark.4.

GET READY. OPEN the Hosting document from the data files for this lesson.
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Troubleshooting

You can adjust the Name column by dragging the resize bar to the right 

to change the width.

Click the Insert button. The dialog box closes and the Confidential watermark 

appears behind the text on every page of the document.

5.

Position the insertion point at the beginning of the first paragraph under 

Introduction.

6.

OPEN the Building Blocks Organizer dialog box again.7.

Click the Gallery heading to sort the building blocks by gallery.8.

Scroll down and select Austin Quote from the Text Boxes gallery. 9.

Click Insert. A pull quote is inserted into the document as shown in Figure 5-13. 

You can type text in the placeholders or drag and drop text in the area.

10.

Figure 5-13

Document with Text Box Pull Quote

Under the heading, Introduction, select the second paragraph beginning with 

Questions or comments . . . 

11.

Move the selected text inside the quote area by dragging and dropping.12.

Click the Show/Hide Editing Marks button and delete both line breaks after the first 

paragraph under Introduction.

13.

Select the text box and then the Layout Options button appears on the right side 

of the text box.

14.

Click the Layout Options button to open the menu. The menu provides options for 

arranging the document text and the text box. 

15.

Click the See more link to open the Layout dialog box.16.

Click the Text Wrapping tab and then click Square.17.

   Lesson 5 Page 14    



Click the Text Wrapping tab and then click Square.17.

Click the Left only option in the Wrap text section. 18.

Click OK.19.

Select the text box border—the pointer changes to four arrows that enables you to 

drag and drop. 

20.

Drag the quote to the end of the first paragraph until the last seven lines of the 

paragraph wrap around it (see Figure 5-14).

21.

Troubleshooting

Deselect the text box and then select it again to see the border around the 

text box.

Figure 5-14

Document with Text Box Pull Quote wrapped around paragraph

Press Ctrl+End to move the insertion point to the end of the document.22.

OPEN the Building Blocks Organizer dialog box.23.

Scroll down and select Motion Sidebar from the Text Boxes gallery.24.

Click Insert. The text box is inserted at the end of the document and positioned on 

the left side. 

25.

Select the paragraph above Refusal of Service beginning with You and Flatland 

Hosting further agree . . . When selecting the paragraph, do not select the 

paragraph mark, to avoid displaying the horizontal line in the text box twice. 

26.

Change the font color to white so that the text will be visible on the sidebar.27.

Drag and drop the selection in the text box.28.

At the top of the text box, delete the [Sidebar Title] placeholder and blank line to 

move the text up one line.

29.
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move the text up one line.

SAVE the document as Hosting 2 in the lesson folder on your flash drive.30.

PAUSE. LEAVE the document open to use in the next exercise.

Step by step           Insert a Cover Page Using Building Blocks

OPEN the Building Blocks Organizer dialog box and then select Whisp in the Cover 

Pages gallery.

1.

Click Insert. The cover page is inserted as page 1.2.

Type the following information in the placeholders:3.

Date: 20XX 

Document Title: Flatland Hosting Company

Document Subtitle: Guidelines & Agreements

Author Name: A. Becker

Remove the placeholder for the Company Name (see Figure 5-15).4.

SAVE the document as Hosting 3 in the lesson folder on your flash drive and then 

CLOSE the file.

5.

GET READY. USE the Hosting 2 document that is open from the previous exercise.

PAUSE. LEAVE Word open to use in the next exercise.

Figure 5-15

Document with Building blocks cover page

Creating and Copying Building Blocks
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Creating and Copying Building Blocks

You can create your own building blocks, to store any text that you use frequently. For 

example, you might create a building block that consists of the signature lines you use 

in business letters, including your name, title, and company name.

When deciding where to store building blocks, consider whether you will want to share 

them with others, and whether you want them available for all documents.

New building blocks that you create in Word are stored by default in the Building 

Blocks.dotx file. This template is automatically enabled all the time, so no matter what 

document you are working on, and no matter what template it uses, the building blocks 

you store there will be available—that is, as long as you are working on the same 

computer and are signed into Windows with the same user account.

You can choose to store building blocks in the active template if you prefer. For 

example, if you create business letters using a template called Business Letters, and you 

save the building blocks in that template, those building blocks will not show up in 

documents created with other templates. If you share that template with others who use 

different computers, the building blocks will be available to them whenever they use 

that template.

You can share your Building Blocks.dotx file with other users on the same computer by 

copying it from the C:\Users\username\AppData\Roaming\Microsoft\Document 

Building Blocks\1033\15 folder, and then pasting it into the corresponding user folder 

for another user account.

You can share the Building Blocks.dotx file with users on different computers by 

emailing them the file or providing it on a disc or flash drive. Make sure you give the 

recipients instructions about where to store the file, so that Word will recognize and use 

it.

The following exercise shows how to create a new building block and then copy the 

Building Blocks.dotx file between user accounts on the same PC.

Step by step           Create and Copy Building Blocks

Type the following signature block, pressing Shift+Enter to create line breaks 

between each line:

Andrew Cencini

General Manager

Flatland Hosting

1.

Select all three lines in the signature block.2.

On the Insert tab, in the Text group, click Quick Parts and then click Save Selection 

to Quick Part Gallery. The Create New Building Block dialog box appears (see Figure 

5-16).

3.

GET READY. CREATE a new blank Word document.
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5-16).

Figure 5-16

Create New Building Block dialog box

In the Name box, type Cencini Signature.4.

Make sure that Building Blocks.dotx is selected in the Save in drop-down list.5.

Click the Options drop-down list and choose Insert content in its own paragraph.6.

Take Note

You can edit the properties of any building block after its creation. From the 

Building Blocks Organizer, select the building block and then click Edit Properties. 

You can change the Gallery, Category, or Description of a building block and then 

save it in a different template. You can also choose whether to save the building 

block as content only or as a paragraph or page.

Click OK.7.

CLOSE the document without saving your changes.8.

CLOSE Word. A message box appears, asking whether you want to save the 

changes to Building Blocks. 

9.

Click Save.10.

In File Explorer, navigate to the C:\Users\username\AppData\Roaming\Microsoft

\Document Building Blocks\1033\16 folder, where username is your user account.

11.

Select the Building Blocks file and then press Ctrl+C to copy the file to the 

Clipboard.

12.

Press Ctrl+V to paste a copy of the file in the same folder.13.

Rename the file Blocks Copy. (To rename the file, press F2, type the new name, and 

then press Enter).

14.

Take Note

The reason that you made a copy of the file and renamed it is so that you don't 

overwrite the existing Building Blocks file in the destination folder in the following 

steps.
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Select Blocks Copy and then press Ctrl+C to copy the file to the Clipboard.15.

Navigate to the folder that your instructor has told you to use for this exercise. For 

example, your instructor may want you to paste the file into the C:\Users\username

\AppData\Roaming\Microsoft\Document Building Blocks\1033\16 folder for some 

other user on the same PC.

16.

Press Ctrl+V to paste the file into the new location.17.

Navigate to the lesson folder on your flash drive and then press Ctrl+V to paste a 

copy of the Blocks Copy file there.

18.

(Optional) If you used another user account in step 16, log in to the user account 

into which you copied the file and then start Word. On the Insert tab, click Quick 

Parts. The Cencini Signature should appear on the top level of the menu, ready for 

use.

19.

PAUSE. LEAVE Word open to use in the next exercise.

Inserting an Equation

Microsoft Word 2016 has built-in equations, which you can insert from the Quick Parts 

gallery or by using the Equation command. When you create a table that contains 

values, you can calculate your answer by inserting an equation. The same rules that you 

learned in Math apply when inserting equations. You can use the Equation Tools Design 

tab, which appears when you insert an equation into a document, to edit or construct 

your own equation. In this exercise, you learn to insert equations in a document.

Step by step           Insert an Equation

On the Insert tab, OPEN the Quick Parts menu and then click Building Blocks 

Organizer.

1.

In the Building Blocks Organizer dialog box, in the Equations gallery, locate and 

then click the Expansion of a Sum equation.

2.

Click Insert. The Expansion of a Sum equation is inserted in the document.3.

Position the insertion point after the equation placeholder and then press the Enter

key twice to place a blank line below the placeholder.

4.

OPEN the Building Blocks Organizer dialog box, locate and click the Area of Circle 

equation, and then click Insert. 

5.

Position the insertion point after the equation placeholder and then press the Enter

key twice to place a blank line below the placeholder.

6.

OPEN the Building Blocks Organizer dialog box, then locate and click the Binomial 

Theorem equation. 

7.

Click Insert. 8.

Click after the equation placeholder and then press the Enter key twice (see Figure 

5-17).

9.

GET READY. CREATE a new blank Word document.
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Figure 5-17

Document containing equations 

SAVE the document as Equations in the lesson folder on your flash drive and then

CLOSE the file.

10.

PAUSE. LEAVE Word open to use in the next exercise.

Inserting a Field from Quick Parts

A field is a placeholder that Word uses to insert content into a document. Word 

automatically uses fields when specific commands are activated, such as those for 

inserting dates, formulas, page numbers, and a table of contents. For example, when 

you insert a date field in a document, the date is updated automatically each time the 

document is opened. In this exercise, you learn to insert a field in a document.

Fields, also called field codes, appear between curly brackets ({ }) when displayed. Field 

codes are turned off by default. To display the field codes in a document instead of the 

information the fields contain, press Alt+F9. You can toggle back and forth to display 

text and field codes by pressing Alt+F9. To edit a field, place the insertion point within 

the field, right-click, and then click Edit Field.

Step by step           Insert the Date and Time

Position the insertion point in the last cell of the table in the second column. 1.

Press Tab to insert a new row. 2.

Take Note

Pressing the Tab key advances the insertion point to the next cell. If you are in the 

last cell of the table, it inserts a row quickly without having to access the Ribbon.

Position the insertion point in the first column, fifth row. Type Total. On the Table 

Tools - Layout tab, in the Alignment group, click the Align Center Right button. 

3.

Press Tab to advance to the next cell. 4.

On the Insert tab, in the Text group, click the Quick Parts button to open the menu.5.

GET READY. OPEN the Billing Table document from the lesson folder.
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On the Insert tab, in the Text group, click the Quick Parts button to open the menu.5.

Click Field on the menu. The Field dialog box appears (see Figure 5-18).6.

Figure 5-18

Field dialog box

The default = (Formula) is selected in the Field names box. Click the Formula

button. The Formula dialog box appears. This is the same dialog box that is 

accessible from the Table Tools - Layout tab. Word automatically reads the values 

listed above the formula and then =SUM(ABOVE) appears in the formula box.

7.

In the Number Format drop-down list, select the third option and then click OK.8.

Place the insertion point on the blank line below the table and then press Enter

three times.

9.

Type Last Updated: in bold and then press the spacebar once after the colon.10.

On the Insert tab, in the Text group, click the Quick Parts button and then click 

Field on the menu.

11.

In the Field dialog box, in the Categories drop-down list, select Date and Time.12.

Troubleshooting

If the Field is shaded in gray, double-click the text in the cell.

In the Field Names list, click Date.13.

In the Date Formats list, select the ninth option with the Day/Month/Year format. 

d MMMM yyyy appears in the Date Formats box. These symbols represent how the 

date will look in your document. 

14.

Click OK to close the dialog box and insert the date field in your document. 15.

The document should look similar to the one shown in Figure 5-19, with the 

exception that the current date will appear.

16.
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exception that the current date will appear.

Figure 5-19

Document with Formula and Date field inserted

On the Home tab, in the Paragraph group, click the Show/Hide Editing Marks

button to hide the marks.

17.

SAVE the document as Billing Update in the lesson folder on your flash drive and 

then CLOSE the file.

18.

PAUSE. LEAVE Word open to use in the next exercise.
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In a long document, it might be useful to refer to other content in the document, such 

as other sections, figures, tables, or individual sentences. You can provide the item's 

name to refer to (for example, "see Figure 1"), but if users are going to be viewing the 

document onscreen, you can save them some time by creating a live link to the content 

to which you are referring.

If the area that you want to refer to in the link has some special status already, such as a 

heading or a numbered figure, equation, or table, you can use a cross-reference to refer 

to it. If the area is just some body text, with no special designation, you must create a 

bookmark to mark the spot; then you can refer to the bookmark in the cross-reference.

Creating a Bookmark

A bookmark is an invisible pointer that you insert in a document. You can insert it 

anywhere in a document and then refer to that bookmark in a cross-reference.

Step by step           Create a Bookmark

Near the middle of page 5, select the text The mailbox size maximum is 15 

megabytes.

1.

On the Insert tab, in the Links group, click Bookmark. (You might need to click Links 

first, depending on the application window width.) The Bookmark dialog box 

appears.

2.

In the Bookmark name text box, type MailboxSize as shown in Figure 5-20.3.

Figure 5-20

Bookmark dialog box

GET READY. OPEN the Hosting document from the lesson folder.

Adding and Linking Content
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Bookmark dialog box

Click Add. The bookmark is created.4.

SAVE the document as Hosting Reference in the lesson folder on your flash drive.5.

PAUSE. LEAVE the document open to use in the next exercise.

Creating a Cross-Reference

A cross-reference is a reference to some other spot in the document. It can be a 

bookmark (like the one you created in the preceding exercise), or a numbered item, 

heading, bookmark, footnote, endnote, equation, figure, or table.

The cross-reference itself can be the actual text of the item being referenced, the page 

number on which it appears, the number of the referenced item (for example, 4 for the 

4th paragraph), the caption of the item (such as for a figure or a table), with or without 

its numbering, or the word above or below.

Step by step           Create a Cross-Reference

In the fifth paragraph on page 2, position the insertion point at the end of the first 

sentence.

1.

On the References tab, in the Captions group, click Cross-reference. The Cross-

reference dialog box appears.

2.

Click the Reference type drop-down list and choose Bookmark. The bookmark you 

created earlier appears on the list, as shown in Figure 5-21.

3.

Figure 5-21

Cross-reference dialog box

GET READY. USE the Hosting Reference document that is open from the previous 

exercise.
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Cross-reference dialog box

In the Insert reference to drop-down list, leave the default Bookmark text value 

selected.

4.

Click Insert. The dialog box remains open.5.

Click Close to close the dialog box. Note that the cross-referenced sentence 

appears in the paragraph. You might need to add a space to separate the 

sentences.

6.

Scroll down to the middle of page 5 and then change 15 to 20 so that the sentence 

now reads: The mailbox size maximum is 20 megabytes.

7.

Scroll back up to page 2, where you inserted the cross-reference. Notice that the 

bookmark still shows the old size.

8.

Right-click the bookmark-inserted sentence and choose Update Field. The 

bookmark is updated to display the new value.

9.

SAVE the document as Hosting Reference 2 in the lesson folder on your flash drive 

and then CLOSE the file.

10.

Inserting Text

Word 2016 also provides the ability to insert text from an outside file into an open 

document. For example, if you want to append the text from a file to the end of your 

open document, or insert the text in the middle of the document, you can do so using 

the Text from File feature. 

Step by step            Inserting Text from a File

Press Ctrl+End to move to the bottom of the document and place the insertion 

point after the final word: Texas.

1.

Press Ctrl+Enter to insert a page break and move the insertion point to the next 

page.

2.

On the Insert tab, in the Text group, click the Object drop-down list and then click 

Text from File. The Insert File combo box appears, which looks almost exactly like 

the standard Open combo box. 

3.

Locate and select the file named References and then click Insert. A new page of 

text appears in the document.

4.

SAVE the document as Resume 2 in the lesson folder on your flash drive. CLOSE

the file.

5.

GET READY. OPEN the Resume document from the lesson folder.

STOP. CLOSE Word.

When you choose Object from the Object drop-down list, the Object dialog box 

appears, as shown in Figure 5-22. Using this dialog box, you can insert a new object or 

an object that you created in another application. 
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Figure 5-22

Object dialog box

For example, if you choose to insert a new Excel chart, a placeholder chart appears in 

the Word document and an Excel window appears, containing the same chart. Any 

modifications to the chart you subsequently make in the Excel window will appear in the 

Word document as well.

If you have an existing file you want to insert into a Word document, you can select the 

Create from File tab in the Object dialog box (see Figure 5-23) and browse to the file. 

Selecting the Link to file checkbox creates a connection to the file you select, so that any 

subsequent changes made to that file will automatically be reflected in the Word 

document. 
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Figure 5-23

Create from File tab in the Object dialog box
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Multiple Choice

boring work.a.

research papers.b.

repetitive work.c.

work that is not performed daily.d.

Macros are used for which of the following?1.

a blank document.a.

an existing document.b.

a template.c.

All of the aboved.

A macro that has been assigned a keyboard shortcut can be run in which of the 

following?

2.

Building Blocks Organizera.

Quick Organizerb.

Text boxc.

Cover Paged.

Which of the following provides a way to manage building blocks by editing, 

deleting, and/or inserting them.

3.

data sourcea.

data fieldb.

field namec.

fieldd.

Which of the following is a placeholder that tells Word to insert changeable data 

into a document?

4.

MarkArta.

Art linkb.

Watermarkc.

SmartArtd.

Which of the following is the term for a customized company logo applied to a 

page background behind a document's text?

5.

Select the best response for the following statements.

True/False

Circle T if the statement is true or F if the statement is false.

T F Macros will not automate tasks.1.

T F When recording a macro, you can format a document with many features to 

enhance the document.

2.

T F When assigning a name to a macro, spaces can be used.3.

T F You can customize a building block.4.

T F After a text box has been inserted, the text box can be moved to another 

location in the document.

5.

Knowledge Assessment
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Project 5-1: Creating a Simple Macro

In your job at Books and Beyond, you work on documents that will be part of the 

employee handbook. You create a simple macro to be used for this employee 

handbook. In this project, you will apply skills that you have learned from previous 

lessons.

OPEN a blank document.1.

On the View tab, click Macros and then click Record Macro in the Macros group.2.

Type the information in the appropriate box:

Macro name: Books_and_Beyond

Description: Formatted report for B&B handbook.

3.

Click Keyboard and in the Press new shortcut key box, type Alt+L. This is an 

unassigned shortcut key.

4.

Click Assign, then click Close.5.

In the Design tab, select the Basic (Stylish) Style Set from the Document Formatting 

group.

6.

Type BOOKS AND BEYOND. Apply Heading 1 from the Styles group on the Home 

tab.

7.

Press Enter once.8.

Type Second section heading.9.

Select Heading 2.10.

Press Enter twice.11.

Type Third section heading.12.

Select Heading 3.13.

Press Enter twice.14.

Click Stop Recording from the Macros group on the View tab.15.

GET READY. LAUNCH Word if not already running.

CLOSE the document without saving. LEAVE Word open for the next project.

Project 5-2: Creating Headers and Footers

SAVE the docu ment as 5-2 First Ladies with Building Blocks in the lesson folder on 

your flash drive.

1.

On the Insert tab, in the Text group, click the Explore QuickParts button and then 

select Building Blocks Organizer. The Building Blocks Organizer dialog box appears.

2.

Scroll down in the Building Blocks list and then select Whisp in the Headers gallery.3.

Click Insert. The header appears, containing the author's name and the title of the 

document.

4.

Click the Date field down-arrow and then click the Today button.5.

Double-click the main body of the document.6.

GET READY. OPEN the First Ladies document from the lesson folder.

Projects
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Double-click the main body of the document.6.

OPEN the Building Blocks Organizer dialog box again.7.

Scroll down in the Building Blocks list and then select Whisp in the Footers gallery.8.

Click Insert. The footer appears, containing the page number.9.

Double-click the main body of the document.10.

SAVE the document in the lesson folder on your flash drive, then CLOSE the file.11.

CLOSE Word.
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