
Lesson Skill Matrix

Skill Exam Objective Objective Number

Working with Fields Add custom fields.

Modify field properties.

3.3.1

3.3.2

Working with Forms Insert and configure content controls.

Display hidden ribbon tabs.

4.1.4

1.1.7

Creating Indexes Mark index entries.

Create indexes.

Update indexes.

3.1.1

3.1.2

3.1.3

Using Fields, Forms, and Indexes
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A field is a code that is used to display variable information. When you update the field, 

if the data on which it is based has changed, the field updates too. One example of a 

field is an automatically updating date or time code that changes to the current date 

and time whenever the field updates.

Understanding Fields

Fields operate behind the scenes in many different contexts in Word. You have worked 

with fields in some exercises in this book already, perhaps without realizing it. For 

example, when you create a table of contents, a bookmark, or a figure caption, you are 

working with a field. Table 6-1 lists some fields and the Word commands that create 

them.

Field Purpose Tab/Command

{Bookmark} Creates a bookmark Insert, Bookmark

{Date} Creates an automatically updating date 

code

Insert, Insert Date and Time

{Hyperlink} Inserts a hyperlink Insert, Hyperlink

{NoteRef} Inserts a footnote number References, Insert Footnote

{Page} Inserts a page numbering code Insert, Page Number

{TOC} Inserts a table of contents References, Table of 

ContentsTable 6-1

Examples of How Fields are Used in Word

There are many kinds of fields. As you learn in Lesson 7, mail merges insert merge fields, 

which are fields that pull certain data from the source document, such as names and 

addresses. You can also insert a variety of fields that describe your document, such as 

the user name, user initials, file name, and so on.

The field codes themselves do not display in the document by default; instead, the result 

of the field codes display. When you toggle on the display of the field codes, however, 

the fields appear in curly braces, like this: {Date}. Each field has a default format that's 

used if the code appears by itself. 

When you customize a field, you add switches to the field code that change the way it 

behaves. A switch is a property or argument that changes the code's behavior. Dialog 

box settings for features that insert a field code, such as Bookmark or Date, determine 

the switches that the field uses. For example, to display the current date in a format like 

August 5, 1964, you would use the following field code:

{DATE \@ "MMMM d, yyyy"}

Inserting Fields

Working with Fields
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Inserting Fields

You can insert fields in a document either by using a command that creates a field code 

as part of its operation or by using the Field command. You practice both methods in 

the following exercise.

When you insert a field, you can customize it by changing the properties in the Field 

dialog box. You can also edit the field's properties to customize the field.

Step by step           Insert Fields

On the Home tab, in the Paragraph group, click the Show/Hide button to display 

formatting symbols.

1.

Delete the date at the top of the document. (Do not delete the paragraph mark.) 

Position the insertion point at the beginning of the document.

2.

On the Insert tab, in the Text group, click the Insert Date and Time button. The 

Date and Time dialog box appears (see Figure 6-1).

3.

Figure 6-1

Date and Time dialog box 

In the Available formats list, select the date format that includes the day of the 

week (Monday, Tuesday, and so on).

4.

Select the Update automatically checkbox.5.

Click OK. The current date appears on the document.6.

Position the insertion point two lines below the Sincerely line.7.

Delete the signer's name. (Do not delete the paragraph mark.)8.

On the Insert tab, in the Text group, click Explore Quick Parts and then click Field. 9.

GET READY. LAUNCH Microsoft Word. OPEN the Tech Terrace letter document from 

the lesson folder.
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On the Insert tab, in the Text group, click Explore Quick Parts and then click Field. 

The Field dialog box appears.

9.

In the Field names list, select UserName.10.

In the Format list, click Title case. See Figure 6-2.11.

Figure 6-2

Field dialog box for a text field

Click OK. The active user name appears in the document.12.

Take Note

The user name comes from the name that is set on the Word Options dialog box. 

To change that name, click the File tab, click Options, and then change the name in 

the User name box.

Right-click the user name in the document and, on the context menu, select Toggle 

Field Codes. The field code appears as follows:

{ USERNAME \* Caps \* MERGEFORMAT }

13.

Right-click the field code and, on the context menu, select Edit Field. The Field

dialog box appears again.

14.

In the Format list, select Uppercase and then click OK. The name now appears in 

uppercase in the document.

15.

SAVE the document as Tech Terrace fields in the lesson folder on your flash drive.16.

PAUSE. LEAVE the document open to use in the next exercise.

Take Note

If you know exactly what you want for your field code and its syntax, you can press 
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If you know exactly what you want for your field code and its syntax, you can press 

Ctrl+F9 to insert a blank field code, complete with an empty set of curly braces, directly 

into the document. You can then type in the desired field code and any special syntax 

required to format it. Field names are not case-sensitive. If a property contains spaces, 

you must enclose that property in quotation marks. Leave one space between the field 

name and each property or switch. Leave one space between the backslash (\) of a 

switch and its parameter. Leave one blank space to the right of the left curly brace and 

one blank space to the left of the right curly brace.

Customizing Field Formats

You can customize a field in a variety of ways. As you saw in the previous exercise, you 

can use the properties in the Field dialog box to assign switches and other arguments to 

a field code. You can set Text fields to Uppercase, Lowercase, First capital, or Title case. 

For numeric fields, you can assign a specific numbering format, such as 1, 2, 3 or A, B, C.

You can also manually edit a field's code to customize it. You do this by toggling on the 

display of the field code and then editing the code string in the document, or by clicking 

the Field Codes button in the Field dialog box and editing the code there. In the 

following exercise, you will practice both methods of customizing a field code.

Step by step           Customize Field Codes

Right-click the date and, on the context menu, select Edit Field. The Field dialog 

box appears.

1.

In the Date formats list, click the format that appears like this: July 7, 2016.2.

Click OK to accept the new format.3.

Double-click at the bottom of the page to open the document footer.4.

Type Rev. and then press the spacebar once.5.

On the Insert tab, click Explore Quick Parts and then click Field.6.

In the Field dialog box, in the Categories list, select Numbering.7.

In the Field names list, select RevNum.8.

In the Format list, select A, B, C.9.

In the Numeric format list, select 0. See Figure 6-3.10.

GET READY. USE the Tech Terrace fields document that is open from the previous 

exercise.
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Figure 6-3

Field dialog box for a numeric field

Click the Field Codes button. The Advanced field properties pane appears.11.

Examine the code that appears in the Field codes box. The word ALPHABETIC

appears in all caps.

12.

Edit the code so that the word alphabetic appears in all lowercase.13.

Click OK. The revision number (a lowercase letter) appears in the footer.14.

Double-click in the main part of the document to close the footer.15.

SAVE the document as Tech Terrace fields 2 in the lesson folder on your flash drive.16.

PAUSE. LEAVE the document open to use in the next exercise.

Creating and Using Custom Fields

A document's properties include several standard fields, such as Author, Title, and 

Subject. You can use the same methods to insert these fields into the document as you 

did with the user name field in the previous exercise. You can also create custom fields 

in the document's properties, and insert the custom fields' content into the document.

In the following exercise, you will create a custom field called Division and then insert it 

in the document.

Step by step           Create and Use Custom Fields

Click the File tab and then, on the backstage Info page, click the down arrow next 

to Properties to open a menu.

1.

Click Advanced Properties. The Properties dialog box for the active document 

appears.

2.

GET READY. USE the document that is open from the previous exercise.
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appears.

Click the Custom tab.3.

In the Name list, select Division.4.

In the Value box, type Midwest. See Figure 6-4.5.

Figure 6-4

Creating a custom field

Click Add and then the new division property appears in the Properties list. 6.

Click OK to close the Properties dialog box. Press Esc to return to the document.7.

After the name on the last line of the document, press Shift+Enter to start a new 

line.

8.

On the Insert tab, in the Text group, click Explore Quick Parts and then click Field. 

The Field dialog box appears.

9.

In the Categories drop-down list, choose Document Information.10.

In the Field names list, click DocProperty.11.

In the Property list, click Division. See Figure 6-5.12.

Click OK. The word Midwest appears in the document.13.

Press the spacebar once and then type Division.14.

SAVE the document as Tech Terrace fields 3 in the lesson folder on your flash drive 

and then CLOSE the file.

15.
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Figure 6-5

Inserting a custom field into a document

PAUSE. LEAVE Word open for the next exercise.

   Lesson 6 Page 8    



In Word, a form is a document that has one or more data collection fields—called 

content controls —inserted, which can contain data. You can create forms that collect 

structured data for documents, such as employment applications, invoices, and 

employee time sheets.

Take Note

As you think about creating a form, visualize how the form fields will align with one 

another. You might want to create a table to hold the fields and their labels to ensure 

that the fields line up neatly.

In the following exercise, you will insert content controls into a document to create a 

form that employees can complete to document their hours worked.

Step by step           Insert Content Controls

To insert content controls, you must first display the Developer tab on the ribbon. 

To do this, click File and then click Options. The Word Options dialog box appears. 

1.

Click Customize Ribbon (see Figure 6-6).2.

In the list on the right, select the Developer checkbox.3.

Click OK. The Developer tab appears.4.

On the Developer tab, in the Controls group, click the Design Mode button. Design 

Mode is a toggle; clicking it activates the mode.

5.

GET READY. OPEN the Time Sheet document from the lesson folder.

Working with Forms
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Figure 6-6

Customize Ribbon tab in the Word Options dialog box

In the document, place the insertion point in the empty cell next to the Employee 

Number cell.

6.

On the Developer tab, in the Controls group, click the Plain Text Content Control

button. (It is the second button on the top row.) A text-based content control 

appears in the cell. See Figure 6-7.

7.

   Lesson 6 Page 10    



Figure 6-7

Inserting a plain text content control

Place the insertion point in the table cell to the right of the cell containing 

Employee Name.

8.

On the Developer tab, in the Controls group, click the Drop-Down List Content 

Control button. A drop-down list content control appears in the cell.

9.

Place the insertion point in the table cell to the right of the cell containing Week 

Ending.

10.

On the Developer tab, in the Controls group, click the Date Picker Content Control

button. A date picker content control appears in the cell.

11.

SAVE the document as Time Sheet Fields in the lesson folder on your flash drive.12.

PAUSE. LEAVE the document open to use in the next exercise.

You can modify a content control's properties by right-clicking the content control and 

choosing Properties. A dialog box appears that is appropriate for the type of content 

control. You can manually edit the text in a content control's prompt by simply changing 

the text in the content control (while in Design Mode).

In the following exercise, you will modify the properties of a content control.

Step by step           Modify Content Control Properties

Click in the content control for Employee Number and then edit the text in the 

control to read Click here to enter your employee number.

1.

Right-click the content control for Employee Name and, on the context menu, 

select Properties. The Content Control Properties dialog box appears.

2.

In the Drop-Down List Properties section, click Add. An Add Choice dialog box 

appears.

3.

GET READY. USE the Time Sheet Fields document that is open from the previous 

exercise.
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appears.

In the Display Name text box, type Dobandi, Barbara. The name is repeated in the 

Value text box. 

4.

Click OK. The name is added to the Drop-Down List Properties box.5.

Repeat Steps 3 to 5 to add the following names:

Engstrom, Esther

Fischer, Peter

Maman, David

Toth, Andras (see Figure 6-8).

6.

Click OK.7.

Figure 6-8

Modify drop-down list control properties

Right-click the content control for Week Ending and, on the context menu, select 

Properties. The Content Control Properties dialog box appears.

8.

In the Date Picker Properties section, select the number format that contains the 

day of the week. See Figure 6-9.

9.
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Figure 6-9

Modify date picker control properties

Click OK to close the dialog box.10.

Click the Design Mode button to toggle Design Mode off. The content controls 

appear as they will when users see the form.

11.

Click in the content control for the employee number and then type 1003.12.

Click in the content control for Employee Name and then select Fischer, Peter.13.

Click in the content control for week ending and then select last Saturday as the 

date.

14.

In the table for the hours, type 8 in the first blank row for Monday, Wednesday, 

and Friday.

15.

SAVE the document as Time Sheet Fields 2 in the lesson folder on your flash drive 

and then CLOSE the file.

16.

PAUSE. LEAVE Word open for the next exercise.
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PAUSE. LEAVE Word open for the next exercise.
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An index is an alphabetical list of the key topics in a document, along with the page 

numbers on which those topics appear. Most non-fiction books include an index at the 

end.

Creating an index in a Word document is a two-step process. In the first step, you mark 

each instance of words that should appear in the index. This can be a very time-

consuming step; for a large document, it can take hours or even days.

In the second step of the process, you issue the command for Word to generate the 

index. It is during this step that the actual index is created. There are numerous options 

for creating indexes with different structures and layouts.

Take Note

Indexing takes some thought because not every instance of every word may be 

appropriate for indexing; only usages that are significant should be included. Creating 

good indexes is a skill that people develop with practice. Some people make a career of 

marking up documents (mostly book manuscripts) for indexing.

Marking Index Entries Manually

One way to mark index entries is to work through the whole document manually, 

marking every instance of each word to be indexed. Each index entry is marked with a 

{XE} field code, with the phrasing and formatting for the index entry as arguments in 

that code. For example:

{XE "Warranties"}

Manually marking the terms to be indexed results in the highest quality index. This is 

because you can exclude certain instances of the words if they are not significant. An 

index with too many irrelevant entries is as useless as one with too few entries. For 

example, imagine how useless it would be to index all instances of the phrase "Microsoft 

Word" in this book you are reading now. It appears on nearly every page. The manual 

method also enables you to use different words to index certain phrases or concepts 

that are synonyms, and to index certain words under two or more different main entries.

Most index entries are main entries—that is, they appear at the top level of 

alphabetization. You can also create subentries, which appear in a separate subordinate 

alphabetized list beneath one of the main entries. For example, if there are multiple skills 

covered pertaining to a certain topic, it might appear in the index like this:

Building, 5

Refinishing, 18

Furniture

Creating Indexes
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Refinishing, 18

Selling, 21

In the following exercise, you will mark some index entries manually in a document.

Step by step           Mark Index Entries Manually

In the second paragraph, under the Women in Politics heading, select the phrase 

creation of the First Lady title.

1.

On the References tab, in the Index group, click Mark Entry. The Mark Index Entry 

dialog box appears.

2.

In the Main entry text box, type First Lady.3.

In the Subentry text box, type creation of title (see Figure 6-10).4.

Click Mark. The formatting symbols are made visible and an {XE} field code appears 

in the document.

5.

Leave the Mark Index Entry dialog box open and then drag it to the side so you can 

see the text behind it.

6.

In the History of First Ladies section, select Warren G. Harding.7.

Figure 6-10

Marking an index entry

In the Mark Index Entry dialog box, place the insertion point in the Main entry text 

box. The Warren G. Harding text appears. 

8.

Click Mark. 9.

In the Main Entry text box, type First Lady. In the Subentry text box, type wife of 

Warren G. Harding. 

10.

Click Mark again.11.

GET READY. OPEN the Research on First Ladies document from the lesson folder.
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Click Mark again.11.

In the Role of First Ladies section, select the phrase social hostesses, spokeswomen 

or political surrogates and independent advocates.

12.

In the Mark Index Entry dialog box, in the Main Entry text box, type First Lady. In 

the Subentry text box, type categories and then click Mark.

13.

In the Power of First Ladies section, select the name Abigail Adams and mark it with 

the Main Entry value of Adams, Abigail.

14.

In the same way, mark the names of the other first ladies in the sentence, creating 

main entries from their names, with the last name first (see Figure 6-11).

15.

Figure 6-11

Index field codes

CLOSE the Mark Index Entry dialog box.16.

SAVE the document as Research on First Ladies Indexed in the lesson folder on 

your flash drive.

17.

PAUSE. LEAVE the document open to use in the next exercise.

Marking Index Entries with an AutoMark File

Another way to mark index entries is to create an AutoMark file. This is a document that 

lists one instance of all the words that should be included in the index. Word can use 

this file to automatically mark all instances of each of the included words in the entire 

document. This method is much faster and easier than manually marking a document, 

but may result in too much marking.

An AutoMark file contains a two-column table. In the left column, type the words or 

phrases that should appear in the index—in other words, the words and phrases to find 

and mark in the document. In the right column, type the words the way they should 

appear in the index.

If you want to create subentries, separate the main entry and subentry with a colon in 

the right column, like this: Furniture:Refinishing.
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the right column, like this: Furniture:Refinishing.

Indexing is case-sensitive, so make sure you include all variations of a word in the right 

column. It's okay to have duplicate entries in the left column.

In the following exercise, you will edit an AutoMark file and then use it to mark up a 

document for indexing.

Step by step           Mark Index Entries Automatically with an AutoMark File

OPEN the AutoMark document from the lesson folder.1.

In the blank rows at the bottom of the table, type the following (see Figure 6-12):

Meringolo Historians:Meringolo, Denise

Mayo Historians:Mayo, Edith

Anthony Historians:Anthony, Carl Sferazza

Gutin Historians:Gutin, Myra 

2.

Figure 6-12

AutoMark entries

SAVE the document as AutoMark Entries and CLOSE the file.3.

In the Research on First Ladies Indexed document, on the References tab, in the 

Index group, click Insert Index. The Index dialog box appears.

4.

Click the AutoMark button. The Open Index AutoMark File dialog box appears.5.

Select the AutoMark Entries file that you saved earlier and then click Open. 

Word automatically marks all of the entries that were listed in the file. 

6.

Take Note

Notice that Word inserts an index field code for all of the occurrences of the terms 

in the AutoMark table.

SAVE the document as Research on First Ladies Indexed 2 in the lesson folder on 

your flash drive.

7.

GET READY. USE the document that is open from the previous exercise.
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your flash drive.

PAUSE. LEAVE the document open to use in the next exercise.

Creating and Updating an Index

After you have completed the markup in a document, you can generate the index. You 

can place an index anywhere in a document, but they are traditionally placed at the end.

In the following exercise, you will generate the index, make a change to the index 

markup, and then update the index.

Step by step           Create and Update an Index

Positio¡n the insertion point at the end of the document and then press Ctrl+Enter

to create a page break.

1.

On the References tab, in the Index group, click Insert Index. The Index dialog box 

appears. See Figure 6-13.

2.

Figure 6-13

Index dialog box

In the Formats drop-down list, choose Classic.3.

Click OK. Word creates the index. Because the index is short, the separate headings 4.

GET READY. USE the document that is open from the previous exercise.
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Click OK. Word creates the index. Because the index is short, the separate headings 

for each letter of the alphabet might seem like overkill.

4.

Notice that the index entry for Warren G. Harding is alphabetized by his first name. 

In the History of First Ladies section of the document, locate the {XE "Warren G. 

Harding"} field code and then change it to read {XE "Harding, Warren G."}.

5.

Right-click anywhere on the index and choose Update Field. The index is updated 

to include Harding, Warren G. under the letter H (see Figure 6-14).

6.

Figure 6-14

Classic index 

Right-click the index again and then choose Edit Field. The Field dialog box 

appears.

7.

Click the Index button. The Index dialog box reappears.8.

In the Formats drop-down list, select Simple.9.

Click OK. A confirmation appears asking if you want to replace the index.10.

Click OK. Word recreates the index using the new format, which does not include 

the alphabet headings (see Figure 6-15).

11.
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Figure 6-15

Simple index

SAVE the document as Research on First Ladies Indexed 3 in the lesson folder on 

your flash drive and then CLOSE the file.

12.

STOP. CLOSE Word.
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Multiple Choice

Double-clicking the fielda.

Right-clicking the field and choosing Edit Fieldb.

Right-clicking the field and choosing Show Field Codec.

Clicking the Modify button on the Insert tabd.

Which of the following actions modifies a field's properties?1.

From the Field dialog box, choose Document Information and then choose 

DocProperty. Then choose the custom field name from the Property list.

a.

Click the Text Box button on the Insert tab.b.

From the Insert tab, select the custom field from the Fields gallery.c.

From the Properties dialog box, on the Custom tab, select the field and choose 

Insert.

d.

Which of the following instructions best describes how to insert a custom field in a 

document?

2.

A merge fielda.

A macrob.

A content controlc.

A moduled.

A form field in Word 2016 is also known as which of the following?3.

Referencesa.

Insertb.

Homec.

Mailingsd.

From which of the following tabs can you select Mark Entry to mark an index entry?4.

right columna.

left columnb.

both columnsc.

neither columnd.

In an AutoMark table, in which column should the text appear as it will appear in 

the index itself?

5.

Select the best response for the following statements.

True/False

Circle T if the statement is true or F if the statement is false.

T F Word uses fields for features such as page numbering and hyperlinks.1.

T F To insert a field in a document, on the Insert tab, click the Code button.2.

T F Custom fields are created in the Properties dialog box for the document.3.

T F To edit a form, you must be in Design Mode.4.

T F An AutoMark file should list all the words to be indexed in a single-column 

list.

5.

Knowledge Assessment
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Project 6-1: Creating a Sign-Up Form

In this project, you will create a form that can be used to sign up for a mailing list.

OPEN the Signup document from the lesson folder.1.

SAVE the document as Signup Form in the lesson folder on your flash drive.2.

Position the insertion point in the blank cell to the right of Today's Date and then 

on the Insert tab, in the Text group, click Explore Quick Parts and then click Field. 

The Field dialog box appears.

3.

Choose Date from the Field names list and choose the date with this format: 8-

Jul-16 from the Date formats list. Click OK.

4.

Click in the blank cell to the right of Name.5.

On the Developer tab, in the Controls group, make sure that Design Mode is 

selected and then click Plain Text Content Control.

6.

Edit the prompt text in the field to read Enter your name here.7.

Click in the blank cell to the right of Email Address.8.

Click Plain Text Content Control.9.

Edit the prompt text in the field to read Enter your email here.10.

Click the Design Mode button to exit that mode.11.

SAVE the document and then CLOSE the file.12.

GET READY. LAUNCH Word if it is not already running.

PAUSE. LEAVE Word open for the next project.

Project 6-2: Indexing a Document

In this project, a section of the Books and Beyond Employee Handbook has been 

updated, and needs to be marked up for indexing.

OPEN the Annual Report document from the lesson folder.1.

SAVE the document as Annual Report Indexed in the lesson folder on your flash 

drive.

2.

Select the first Heading 1 heading (To Our Stockholders).3.

On the References tab, in the Index group, click Mark Entry.4.

Click the Mark button.5.

Scroll down and select the next Heading 1 heading (Financial Summary). 6.

In the Mark Index Entry dialog box, click in the Main entry text box and then click 

Mark.

7.

Scroll down and select the next Heading 1 heading (Financial Statements). 8.

In the Mark Index Entry dialog box, click in the Main entry text box and then click 

Mark.

9.

Scroll down and select the next Heading 1 heading (Notes to Financial Statements). 10.

In the Mark Index Entry dialog box, click in the Main entry text box and then click 11.

GET READY. LAUNCH Word if it is not already running.

Projects
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In the Mark Index Entry dialog box, click in the Main entry text box and then click 

Mark.

11.

Scroll down and select the next Heading 1 heading (Independent Auditor's Report). 12.

In the Mark Index Entry dialog box, click in the Main entry text box and then click 

Mark.

13.

Scroll down and select the next Heading 1 heading (Contact Information). 14.

In the Mark Index Entry dialog box, click in the Main entry text box and then click 

Mark.

15.

Scroll down and select the next Heading 1 heading (Company Information). 16.

In the Mark Index Entry dialog box, click in the Main entry text box and then click 

Mark.

17.

Close the Mark Index Entry dialog box.18.

SAVE the document and then CLOSE the file.19.

CLOSE Word.
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